With the ''show version'' command the IOS version information and router information are shown

SanJose2#sh version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(32), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Fri 02-Dec-05 22:15 by
Image text-base: 0x8000808C, data-base: 0x8147134C

ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)

SanJose2 uptime is 46 minutes
System returned to ROM by power-on
System image file is "flash:c2600-js-mz.122-32.bin"

cisco 2620XM (MPC860P) processor (revision 0x200) with 89088K/9216K bytes of mem
ory.
Processor board ID JAE08072CF4 (4243966769)
M860 processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Basic Rate ISDN software, Version 1.1.
1 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

With the ''show running-config''command you can display your current router configuration:


SanJose2#sh run
Building configuration...

Current configuration : 786 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SanJose2
!
enable secret 5 $1$Yf4o$NRL.O/ppepC0.KvOy1LkE1
!
memory-size iomem 10
ip subnet-zero
!
!
!
clns routing
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
 ip router isis
!
interface FastEthernet0/0
 ip address 172.16.0.2 255.255.255.0
 ip router isis
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
!
router isis
 net 49.0001.2222.2222.2222.00
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 020F175218
 login
!
end

show & debugging commands:

With the ''show clns neighbors'' command you can verify the adjacencies you have.
SanJose2#sh clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
SanJose1       Fa0/0       0013.c4a6.a7e0      Up     9         L1L2 IS-IS
SanJose3       Fa0/0       000f.341c.9460      Up     27        L1L2 IS-IS
With the ''show clns protocol'' command you can verify the system ID, the area address and the IS type
SanJose2#sh clns protocol

IS-IS Router: <Null Tag>
  System Id: 2222.2222.2222.00  IS-Type: level-1-2
  Manual area address(es):
        49.0001
  Routing for area address(es):
        49.0001
  Interfaces supported by IS-IS:
        FastEthernet0/0 - IP
        Loopback0 - IP
  Redistribute:
    static (on by default)
  Distance for L2 CLNS routes: 110
  RRR level: none
  Generate narrow metrics: level-1-2
  Accept narrow metrics:   level-1-2
  Generate wide metrics:   none
  Accept wide metrics:     none
With the ''show isis database'' command you can display the different Link State Packet entries in the IS-IS database
SanJose2#sh isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
SanJose1.00-00        0x00000009   0x751F        567               0/0/0
SanJose1.02-00        0x00000006   0x8C6A        1101              0/0/0
SanJose2.00-00      * 0x00000006   0x2FEC        998               0/0/0
SanJose3.00-00        0x00000006   0xE2BD        1064              0/0/0
SanJose3.02-00        0x00000001   0x596D        0 (293)           0/0/0
IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
SanJose1.00-00        0x0000000A   0xCE7C        567               0/0/0
SanJose1.02-00        0x00000006   0x3E41        1117              0/0/0
SanJose2.00-00      * 0x00000007   0xBF1D        572               0/0/0
SanJose3.00-00        0x00000007   0x0566        570               0/0/0
SanJose3.02-00        0x00000001   0x596D        0 (293)           0/0/0
The ''show isis topology'' shows the metric value, the level hierarchy and where the Next-hop router is.
SanJose2#sh isis topology

IS-IS paths to level-1 routers
System Id             Metric  Next-Hop              Interface   SNPA
SanJose1              10      SanJose1              Fa0/0       0013.c4a6.a7e0

SanJose2              --
SanJose3              10      SanJose3              Fa0/0       000f.341c.9460


IS-IS paths to level-2 routers
System Id             Metric  Next-Hop              Interface   SNPA
SanJose1              10      SanJose1              Fa0/0       0013.c4a6.a7e0

SanJose2              --
SanJose3              10      SanJose3              Fa0/0       000f.341c.9460
SanJose2#sh clns route
Codes: C - connected, S - static, d - DecnetIV
       I - ISO-IGRP,  i - IS-IS,  e - ES-IS

C  49.0001.2222.2222.2222.00 [1/0], Local IS-IS NET
C  49.0001 [2/0], Local IS-IS Area
SanJose2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

i L1 192.168.30.0/24 [115/20] via 172.16.0.3, FastEthernet0/0
i L1 192.168.10.0/24 [115/20] via 172.16.0.1, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, FastEthernet0/0
C    192.168.20.0/24 is directly connected, Loopback0
SanJose2#sh clns interface
FastEthernet0/0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  ERPDUs enabled, min. interval 10 msec.
  RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
  Congestion Experienced bit set at 4 packets
  CLNS fast switching enabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 21 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x1, local circuit ID 0x2
    Level-1 Metric: 10, Priority: 64, Circuit ID: SanJose1.02
    Number of active level-1 adjacencies: 2
    Level-2 Metric: 10, Priority: 64, Circuit ID: SanJose1.02
    Number of active level-2 adjacencies: 2
    Next IS-IS LAN Level-1 Hello in 4 seconds
    Next IS-IS LAN Level-2 Hello in 2 seconds
Serial0/0 is administratively down, line protocol is down
  CLNS protocol processing disabled
BRI0/0 is administratively down, line protocol is down
  CLNS protocol processing disabled
BRI0/0:1 is administratively down, line protocol is down
  CLNS protocol processing disabled
BRI0/0:2 is administratively down, line protocol is down
  CLNS protocol processing disabled
Serial0/1 is administratively down, line protocol is down
  CLNS protocol processing disabled
Loopback0 is up, line protocol is up
  Checksums enabled, MTU 1514, Encapsulation LOOPBACK
  ERPDUs enabled, min. interval 10 msec.
  RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
  Congestion Experienced bit set at 4 packets
  CLNS fast switching disabled
  CLNS SSE switching disabled
  DEC compatibility mode OFF for this interface
  Next ESH/ISH in 32 seconds
  Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: SanJose2.01
    Number of active level-1 adjacencies: 0
    Level-2 Metric: 10, Priority: 64, Circuit ID: SanJose2.01
    Number of active level-2 adjacencies: 0
    Next IS-IS LAN Level-1 Hello in 88 milliseconds
    Next IS-IS LAN Level-2 Hello in 6 seconds

Exercise part 2 - level changing

 
771sanjose2.txt · Last modified: 2009/09/13 14:37 (external edit)
 
Except where otherwise noted, content on this wiki is licensed under the following license:CC Attribution-Noncommercial-Share Alike 3.0 Unported
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki