With the ''show version'' command the IOS version information and router information are shown

Router#sh version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(32), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Fri 02-Dec-05 22:15 by
Image text-base: 0x8000808C, data-base: 0x8147134C

ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)

Router uptime is 5 minutes
System returned to ROM by power-on
System image file is "flash:c2600-js-mz.122-32.bin"

cisco 2611XM (MPC860P) processor (revision 0x401) with 118784K/12288K bytes of m
emory.
Processor board ID FCZ0929702M (2714435541)
M860 processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Basic Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

With the ''show controllers serial 0/0'' command you can find out if the router is DTE or DCE:


RT1#sh controllers serial 0/0
Interface Serial0/0
Hardware is PowerQUICC MPC860
DCE V.35, clock rate 64000
....

With the ''show running-config''command you can display your current router configuration:

RT1#sh run
Building configuration...

Current configuration : 908 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RT1
!
enable secret 5 $1$DdrN$AAPe5AFueyvgr6eEulh0w0
!
memory-size iomem 10
ip subnet-zero
!
!
no ip domain-lookup
!
clns routing
call rsvp-sync
!
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.252
 ip router isis
 no fair-queue
 clock rate 64000
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
!
router isis
 net 49.0001.0000.0000.0001.00
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password isis
 login
!
end

show & debugging commands:

With the ''show clns neighbors'' command you can verify the adjacencies you have. In this output you can see that router RT2 is a neighbor to router RT1
RT1#sh clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
RT2            Se0/0       *HDLC*              Up     27        L1L2 IS-IS
With the ''show clns protocol'' command you can verify the system ID, the area address and the IS type
RT1#sh clns protocol

IS-IS Router: <Null Tag>
  System Id: 0000.0000.0001.00  IS-Type: level-1-2
  Manual area address(es):
        49.0001
  Routing for area address(es):
        49.0001
  Interfaces supported by IS-IS:
        Serial0/0 - IP
        Loopback0 - IP
  Redistribute:
    static (on by default)
  Distance for L2 CLNS routes: 110
  RRR level: none
  Generate narrow metrics: level-1-2
  Accept narrow metrics:   level-1-2
  Generate wide metrics:   none
  Accept wide metrics:     none
With the ''show isis database'' command you can display the different Link State Packet entries in the IS-IS database
RT1#sh isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
RT1.00-00           * 0x00000005   0xA8F2        552               0/0/0
RT2.00-00             0x00000003   0xB7E2        551               0/0/0
IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
RT1.00-00           * 0x00000006   0xE505        558               0/0/0
RT2.00-00             0x00000004   0x5C8E        557               0/0/0
The ''show isis topology'' shows the metric value, the level hierarchy and where the Next-hop router is. The serial encapsulation protocol is HDLC
RT1#sh isis topology

IS-IS paths to level-1 routers
System Id             Metric  Next-Hop              Interface   SNPA
RT1                   --
RT2                   10      RT2                   Se0/0       *HDLC*


IS-IS paths to level-2 routers
System Id             Metric  Next-Hop              Interface   SNPA
RT1                   --
RT2                   10      RT2                   Se0/0       *HDLC*
With the following commands the serial encapsultions protocol is changed to PPP
RT1(config)#interface serial 0/0
RT1(config-if)#encapsulation ppp
In this output you can see that the new serial encapsultions protocol is PPP
RT1#sh isis topology

IS-IS paths to level-1 routers
System Id             Metric  Next-Hop              Interface   SNPA
RT1                   --
RT2                   10      RT2                   Se0/0       *PPP*


IS-IS paths to level-2 routers
System Id             Metric  Next-Hop              Interface   SNPA
RT1                   --
RT2                   10      RT2                   Se0/0       *PPP*
With the ''ping'' command you can check connectivity between two routers. In this output you can see that router RT1 has a connection to router RT2
RT1#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
Another possibility to test the connection between two routers is the ''telnet'' command. If the enable secret password and the vty password are configured on a router you want to connect you have to put in these two passwords during the login process
RT1#telnet 192.168.1.2
Trying 192.168.1.2 ... Open


User Access Verification

Password:
RT2>ena
Password:
RT2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RT2(config)#^Z
RT2#exit

[Connection to 192.168.1.2 closed by foreign host]
 
router1.txt · Last modified: 2009/09/13 14:37 (external edit)
 
Except where otherwise noted, content on this wiki is licensed under the following license:CC Attribution-Noncommercial-Share Alike 3.0 Unported
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki